SimplyVideo supports all SIP and H.323 video devices as standard. The details for leading manufacturers and services are outlined below. If you're device isn't featured, get in touch and we'll do what we can to help.

Tandberg or Cisco

Cisco Tandberg

Tandberg T1 and T3 fall under C-series so there's no TIP support. Tandberg Integrator, Intern, Fieldview, and Maestro are included under MXP.

Using older firmware versions may produce some functionality limitations as our service continues to evolve. We strongly recommend that current firmware versions are used to take advantage of the latest device features and security patches available at https://software.cisco.com/.

Polycom / Poly

Poly

Using older firmware versions may produce some functionality limitations as our service continues to evolve. We strongly recommend that current firmware versions are used to take advantage of the latest device features and security patches available at Poly / Polycom support

Huawei

Huawei

Note: Using older firmware versions may produce some functionality limitations as our service continues to evolve. We strongly recommend that current firmware versions are used to take advantage of the latest device features and security patches available as below:

English -> Select other TE-Series models from the TE30 pulldown menu.
Chinese -> Select other TE-Series models from the TE30 pulldown menu.

Yealink

Yealink

Using older firmware versions may produce some functionality limitations as our service continues to evolve. We strongly recommend that current firmware versions are used to take advantage of the latest device features and security patches available at:- Yealink Support

Lifesize

Lifesize 220s, including Lifesize Room 220, Lifesize Room 220i, Lifesize Team 220, and Lifesize Express 220 requires version 4.12.3 or newer to function correctly. Presentation/content is not supported on lower software versions.

Please note, most calling functions are available, but if a Lifesize system has a URI (name) longer than 30 characters including the domain, we do not support this, due to limitations on the vendor's devices.

RealWear devices

RealWear

Using older firmware versions may produce some functionality limitations as our service continues to evolve. We strongly recommend that current firmware versions are used to take advantage of the latest device features and security patches available by saying "My programs", follows by "Check for updates" on your headset.

Other devices

If your hardware is not listed above (including Radvision, Polyspan, Polycom VSX/QDX/Viewstation, Tandberg Classic, Sony, Aethra, or any others, please contact us.